Help - Search - Members - Calendar
Full Version: Can't connect to engine ECU anymore.
Alfa Romeo 145 - 146 Forum > Technical > ECU Diagnostics
benedusi
Last week, for no reason, the car didn't start, I tried to scan for errors using the VAG-COM and multiecuscan but it won't connect to the engine ECU as it used to, I tried with the ABS ECU and it connects right away.
Couple of hours after I gave up, the car just starts fine with no warning lights, but still no connection with the ECU. So I took the car to the mechanic to see if we could connect with the "real deal" scanner, and nothing.
Any ideas what could be wrong?
benedusi
Fixed, the floor on the passenger side was wet, probably the humidity had affected the ECU, so, I took it out, cleaned the connector, plug it in again and done.
Also I discovered that the drain holes were filled with dirt, and that caused the water to enter the cabin.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2020 Invision Power Services, Inc.