Help - Search - Members - Calendar
Full Version: Fix Your Heated Rear Screen For Free
Alfa Romeo 145 - 146 Forum > Technical > FAQ
Biggles146
I had a non-functioning heated screen (and mirrors), all diag pointing to the relay, it was still clicking, just when tested out of the car the HT side was always open circuit. I got a replacement relay from another car when I bought a front pipe, yet this relay seemed to be broken too. sad.gif

The relay:


So prize it open with a screwdriver. I found this in both of the relays:





The solder joint which seems to be broken is for one of the pads of the HT side of the relay, that'll be why it wasn't working then. Resolder the joint and you're back in business.
930Tech
Good thread, should go in the how to guides i'd say. thumbsup.gif
NaanBread
2nd that! smile.gif
kirk46
biggrin.gif

work for me!!!!

it melted a bit of the plastic too.... put a boiled kettle in the back window and turn it on.... and it worked!!

great stuff
Alanos
Thanks for this! Sorted mine in 2 minutes flat, exact same fault on the relay. The less tricky of my current problems, but still one that has been bugging me for weeks, so thanks a lot :-)
alfizta
would a generic 12V 30A 4 pin relay do the trick?
Ganz
QUOTE(alfizta @ 14th November 2015 10:57) *
would a generic 12V 30A 4 pin relay do the trick?


Make sure the wiring diagram is the same. Sometimes, even if the pins and voltage are the same, the wiring is different.
IgoRR
Thank you ALLOT for the thread and the useful information about the heating relay.

I re-soldered mine, and now it works.

Thank you. coolio.gif
peter79
Where is this relay located? smile.gif
GialloEvo94
QUOTE(peter79 @ 10th October 2016 15:34) *
Where is this relay located? smile.gif

It's usually located in the main fuse box (which is under the dashboard above the pedals) at the far bottom left. See the picture in this post. The heated rear screen relay is the square black relay located directly below the circled yellow rectangular central locking control unit in that picture.

The relay you are looking for will either be black with part number 60652355 on it, or it will be grey with part number 60630605 on it.
peter79
QUOTE(GialloEvo94 @ 12th October 2016 00:28) *
It's usually located in the main fuse box (which is under the dashboard above the pedals) at the far bottom left. See the picture in this post. The heated rear screen relay is the square black relay located directly below the circled yellow rectangular central locking control unit in that picture.

The relay you are looking for will either be black with part number 60652355 on it, or it will be grey with part number 60630605 on it.


Thanks, found it. Seems to work okay.

And today the heating in the mirrors and rear window worked okay. Might just the be Alfa charm smile.gif

Next job: Make the radio turn off when i turn off ignition... Now it just keeps playing when i turn off the ignition. I think it the original Sony radio.

Any ideas on what i should do?

Thanks
GialloEvo94
QUOTE(peter79 @ 12th October 2016 07:32) *
Next job: Make the radio turn off when i turn off ignition... Now it just keeps playing when i turn off the ignition. I think it the original Sony radio.

Any ideas on what i should do?

Yep, see the following thread...

http://forum.alfa145.com/index.php?showtopic=22793

smile.gif
pyle
I get excessive load when I turn the heater for the screen, could this fault have any relation?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2021 Invision Power Services, Inc.