Help - Search - Members - Calendar
Full Version: Twin Spark Engine Only Oily Stuff
Alfa Romeo 145 - 146 Forum > Technical > Twin Spark Engine Only Oily Stuff
Pages: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16
  1. Oil cooler? 146 ti 2.0 ts (2 replies)
  2. Water in my well (6 replies)
  3. Alfa Romeo 1.8 TS - weird idle (10 replies)
  4. Last Chance before the matches come out... (2 replies)
  5. I installed variable intake manifold on 1,6TS (11 replies)
  6. Blue Smoke? (18 replies)
  7. What is the right engine temperature for an AR 145/146? (28 replies)
  8. Fuel Pump (15 replies)
  9. Sump plug thread (4 replies)
  10. Core Plug? (6 replies)
  11. Crankshaft Big End Journals (11 replies)
  12. Clutch Pilot/Spigot bearing (4 replies)
  13. Does anyone recognise this piston? (9 replies)
  14. Choke mods (1 reply)
  15. 145 Cloverleaf Coolant Pressurised (9 replies)
  16. How to Clean inside Motor for chips on Oil (1 reply)
  17. My Alfa 145 QV Died (6 replies)
  18. Cloverleaf hesitation when cold (17 replies)
  19. Pistons (2 replies)
  20. Pistons (0 replies)
  21. Diy Cambelt Change (57 replies)
  22. QV won't start (42 replies)
  23. Accelerate issue (0 replies)
  24. ECU codes on 1996 CF1 146 TI (2 replies)
  25. Moved: Selespeed Manual (-- replies)
  26. 2.0 TS alloy cover VS plastic cover (11 replies)
  27. Fuel and exhaust smell - in and out (6 replies)
  28. Serpentine power steering hose (8 replies)
  29. Alfa 145 QV Exhaust pulley part number? (6 replies)
  30. Fuel Pump plugs leak (3 replies)
  31. MoT fail on emissions - diagnosis? (9 replies)
  32. Almost stalls on first start of the day. (5 replies)
  33. Problem With Heater After New Radiator (3 replies)
  34. 146 1.8 juddering on over-run (7 replies)
  35. Alfa Romeo 146 no power (12 replies)
  36. High engine rpm when cold and revs hanging when shifting gear (14 replies)
  37. 146 ti 2.0 (1 reply)
  38. Ticking/clicking from throttle body (2 replies)
  39. Electric Fan On.. A Lot! (8 replies)
  40. Headlight brow. (4 replies)
  41. Well it's done (1 reply)
  42. Mick needs help on the darkside (3 replies)
  43. Would You Trust Ebay Icv (4 replies)
  44. Lost Valve (6 replies)
  45. Hick up at Revs (5 replies)
  46. Missing under load (after giving it a little bit of stick!) (2 replies)
  47. Ph1 coolant expansion tank (3 replies)
  48. Fuel Problems (AGAIN) (10 replies)
  49. Cooling Issue (4 replies)
  50. Cam Lobe Wear 2.0TS (0 replies)
  51. Coil pack question with HT leads mixed in. (2 replies)
  52. Alfa 145 1.4 16v Cam Upgrade (9 replies)
  53. 145 1.4ts, Idle Issues After Warming Up (13 replies)
  54. 145, 1.8ts Ar67106 Wont Idle (12 replies)
  55. Engine Rebuild ? (2 replies)
  56. Brake Light Switch (under Dash) (1 reply)
  57. Gear Stick Has Dropped (10 replies)
  58. Fuel Pump Wiring (6 replies)
  59. And So The Bad News Continues For My Poor Qv (6 replies)
  60. Variator,injector Light On (8 replies)
  61. Hesitation When Cold And Hard Start (6 replies)
  62. Which Gearbox To Use (6 replies)
  63. Fan Speed (1. And 2.) Relay And Fuse Location (12 replies)
  64. Variator Solenoid Dissected (7 replies)
  65. Leaking Fuel (25 replies)
  66. She Goes (5 replies)
  67. 146ti Oil Capacity (4 replies)
  68. Aux Belt Route.. (16 replies)
  69. Engine Died Wile Driving (11 replies)
  70. Idle To Near Stall (10 replies)
  71. Location Of Fuel Pressure Regulator (1 reply)
  72. Temp Sender Alert (2 replies)
  73. Idle To Near Stall (0 replies)
  74. Fuel Pressure Regulator (6 replies)
  75. High Emission Engine Rebuild (7 replies)
  76. Alfa 146ti Accident Rear Ended :( (4 replies)
  77. Cold Start Sensor (3 replies)
  78. The 'misfire' Continues... P1173 (22 replies)
  79. Oh Friday The 13th.. (13 replies)
  80. Misfire When Engine Hot? (2 replies)
  81. Gearbox Change (4 replies)
  82. Oh, Sh*t. (13 replies)
  83. Main Bearings (17 replies)
  84. Squealing At 2500rpm When Cold - 146ti 2.0 Ts (6 replies)
  85. Torque Specs For Stretch Bolts (7 replies)
  86. Water Temperature Low (2 replies)
  87. Cf Code For Engine (1 reply)
  88. Overheating (37 replies)
  89. Lambda Part Number (8 replies)
  90. Relays Location (9 replies)
  91. 146 2.0 Ti Running Issues (3 replies)
  92. 146 Ti Enough Torque, But More Than Less Hp (27 replies)
  93. Manual Fan Switch (4 replies)
  94. 2.5v6 For 145 (1 reply)
  95. Basically Fxxked Just Going Through Mot + Camshafts Upgrade? (15 replies)
  96. 146 1.4 Ts Problems (2 replies)
  97. Crank Sensor (4 replies)
  98. 146 Exhaust (0 replies)
  99. Engine Runs Rough (7 replies)
  100. Where Can I Get Rear Brake Pipes From (10 replies)
  101. A Question For G E Or Anyone (6 replies)
  102. Where Can I Get.... (1 reply)
  103. What's This? (5 replies)
  104. Injector Light On? (6 replies)
  105. Gearbox Refurb (4 replies)
  106. Engine Temperature (16 replies)
  107. Cambelt Change - How Often (12 replies)
  108. Ignition Injector Light Stays On (29 replies)
  109. Cam Belt, Variator Price (10 replies)
  110. Coolant Tank Cap (4 replies)
  111. Misfiring 146 (22 replies)
  112. Phase Sensor (11 replies)
  113. Oil Leak :-/ (16 replies)
  114. Resonator Replacement With A Straight Through Pipe (55 replies)
  115. Cat Back Silencer Or Not? (11 replies)
  116. Tapping And Squeaking (3 replies)
  117. Cat Removed (8 replies)
  118. Problems With 146 Ti (14 replies)
  119. Cheap Genuine Bosch Maf :) (31 replies)
  120. Power Loss And Rev Hunting (5 replies)
  121. Possible Maf Faliure (4 replies)
  122. Cracked Rocker Cover (11 replies)
  123. A Few Little Problems..... (8 replies)
  124. Twin Spark Engine Removal / Replacement Started (94 replies)
  125. Crank Sensor Replacement (8 replies)
  126. 2.0 Cambelt Kit (4 replies)
  127. Engine Removal (9 replies)
  128. Running Without Lambda (3 replies)
  129. Broke Strut Tower Bolt! (9 replies)
  130. Cam Belt Tools Needed (2 replies)
  131. Gasket Cylinder Head Cover (3 replies)
  132. From Which Alfa/fiat/lancia Gearboxes Does A Longer 5. Gear Fit A Qv (8 replies)
  133. Cf1 (alloy Top Engine) Relay Information Needed? (8 replies)
  134. Oil Pressure Light Slow To Go Out When Cold (4 replies)
  135. Brokendown Help (6 replies)
  136. Cone Filter? (10 replies)
  137. What Could Be Wrong With This Car? (6 replies)
  138. Speedometer Doesn't Work Error 64 (18 replies)
  139. Gearbox Oil (22 replies)
  140. Car Won't Start (5 replies)
  141. Trying To Remove The Sump Plug (3 replies)
  142. Twinspark Ticking Noise (could Be Oil Related) (5 replies)
  143. Throttle Valve - Does This Need Cleaning? (12 replies)
  144. Water Temp Sensor? (8 replies)
  145. Alfa 145 1.4? (15 replies)
  146. Loctite Oil Cooler Fitting? (3 replies)
  147. Front Brake Pipe Replacement (3 replies)
  148. Luckily I Work For... (8 replies)
  149. Oil Pressure Problem (19 replies)
  150. Bbob Traumas (9 replies)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.