Help - Search - Members - Calendar
Full Version: Twin Spark Engine Only Oily Stuff
Alfa Romeo 145 - 146 Forum > Technical > Twin Spark Engine Only Oily Stuff
Pages: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16
  1. Diy Cambelt Change (57 replies)
  2. QV won't start (42 replies)
  3. Accelerate issue (0 replies)
  4. ECU codes on 1996 CF1 146 TI (2 replies)
  5. Moved: Selespeed Manual (-- replies)
  6. 2.0 TS alloy cover VS plastic cover (11 replies)
  7. Fuel and exhaust smell - in and out (6 replies)
  8. Serpentine power steering hose (8 replies)
  9. Alfa 145 QV Exhaust pulley part number? (6 replies)
  10. Fuel Pump plugs leak (3 replies)
  11. Cloverleaf hesitation when cold (16 replies)
  12. MoT fail on emissions - diagnosis? (9 replies)
  13. Almost stalls on first start of the day. (5 replies)
  14. Problem With Heater After New Radiator (3 replies)
  15. 146 1.8 juddering on over-run (7 replies)
  16. Alfa Romeo 146 no power (12 replies)
  17. High engine rpm when cold and revs hanging when shifting gear (14 replies)
  18. 146 ti 2.0 (1 reply)
  19. Ticking/clicking from throttle body (2 replies)
  20. Electric Fan On.. A Lot! (8 replies)
  21. Headlight brow. (4 replies)
  22. Well it's done (1 reply)
  23. Mick needs help on the darkside (3 replies)
  24. Would You Trust Ebay Icv (4 replies)
  25. Lost Valve (6 replies)
  26. Hick up at Revs (5 replies)
  27. Missing under load (after giving it a little bit of stick!) (2 replies)
  28. Ph1 coolant expansion tank (3 replies)
  29. Fuel Problems (AGAIN) (10 replies)
  30. Cooling Issue (4 replies)
  31. Cam Lobe Wear 2.0TS (0 replies)
  32. Coil pack question with HT leads mixed in. (2 replies)
  33. Alfa 145 1.4 16v Cam Upgrade (9 replies)
  34. 145 1.4ts, Idle Issues After Warming Up (13 replies)
  35. 145, 1.8ts Ar67106 Wont Idle (12 replies)
  36. Engine Rebuild ? (2 replies)
  37. Brake Light Switch (under Dash) (1 reply)
  38. Gear Stick Has Dropped (10 replies)
  39. Fuel Pump Wiring (6 replies)
  40. And So The Bad News Continues For My Poor Qv (6 replies)
  41. Variator,injector Light On (8 replies)
  42. Hesitation When Cold And Hard Start (6 replies)
  43. Which Gearbox To Use (6 replies)
  44. Fan Speed (1. And 2.) Relay And Fuse Location (12 replies)
  45. Variator Solenoid Dissected (7 replies)
  46. Leaking Fuel (25 replies)
  47. She Goes (5 replies)
  48. 146ti Oil Capacity (4 replies)
  49. Aux Belt Route.. (16 replies)
  50. Engine Died Wile Driving (11 replies)
  51. Idle To Near Stall (10 replies)
  52. Location Of Fuel Pressure Regulator (1 reply)
  53. Temp Sender Alert (2 replies)
  54. Idle To Near Stall (0 replies)
  55. Fuel Pressure Regulator (6 replies)
  56. High Emission Engine Rebuild (7 replies)
  57. Alfa 146ti Accident Rear Ended :( (4 replies)
  58. Cold Start Sensor (3 replies)
  59. The 'misfire' Continues... P1173 (22 replies)
  60. Oh Friday The 13th.. (13 replies)
  61. Misfire When Engine Hot? (2 replies)
  62. Gearbox Change (4 replies)
  63. Oh, Sh*t. (13 replies)
  64. Main Bearings (17 replies)
  65. Squealing At 2500rpm When Cold - 146ti 2.0 Ts (6 replies)
  66. Torque Specs For Stretch Bolts (7 replies)
  67. Water Temperature Low (2 replies)
  68. Cf Code For Engine (1 reply)
  69. Overheating (37 replies)
  70. Lambda Part Number (8 replies)
  71. Relays Location (9 replies)
  72. 146 2.0 Ti Running Issues (3 replies)
  73. 146 Ti Enough Torque, But More Than Less Hp (27 replies)
  74. Manual Fan Switch (4 replies)
  75. 2.5v6 For 145 (1 reply)
  76. Basically Fxxked Just Going Through Mot + Camshafts Upgrade? (15 replies)
  77. 146 1.4 Ts Problems (2 replies)
  78. Crank Sensor (4 replies)
  79. 146 Exhaust (0 replies)
  80. Engine Runs Rough (7 replies)
  81. Where Can I Get Rear Brake Pipes From (10 replies)
  82. A Question For G E Or Anyone (6 replies)
  83. Where Can I Get.... (1 reply)
  84. What's This? (5 replies)
  85. Injector Light On? (6 replies)
  86. Gearbox Refurb (4 replies)
  87. Engine Temperature (16 replies)
  88. Cambelt Change - How Often (12 replies)
  89. Ignition Injector Light Stays On (29 replies)
  90. Cam Belt, Variator Price (10 replies)
  91. Coolant Tank Cap (4 replies)
  92. Misfiring 146 (22 replies)
  93. Phase Sensor (11 replies)
  94. Oil Leak :-/ (16 replies)
  95. Resonator Replacement With A Straight Through Pipe (55 replies)
  96. Cat Back Silencer Or Not? (11 replies)
  97. Tapping And Squeaking (3 replies)
  98. Cat Removed (8 replies)
  99. Problems With 146 Ti (14 replies)
  100. Cheap Genuine Bosch Maf :) (31 replies)
  101. Power Loss And Rev Hunting (5 replies)
  102. Possible Maf Faliure (4 replies)
  103. Cracked Rocker Cover (11 replies)
  104. A Few Little Problems..... (8 replies)
  105. Twin Spark Engine Removal / Replacement Started (94 replies)
  106. Crank Sensor Replacement (8 replies)
  107. 2.0 Cambelt Kit (4 replies)
  108. Engine Removal (9 replies)
  109. Running Without Lambda (3 replies)
  110. Broke Strut Tower Bolt! (9 replies)
  111. Cam Belt Tools Needed (2 replies)
  112. Gasket Cylinder Head Cover (3 replies)
  113. From Which Alfa/fiat/lancia Gearboxes Does A Longer 5. Gear Fit A Qv (8 replies)
  114. Cf1 (alloy Top Engine) Relay Information Needed? (8 replies)
  115. Oil Pressure Light Slow To Go Out When Cold (4 replies)
  116. Brokendown Help (6 replies)
  117. Cone Filter? (10 replies)
  118. What Could Be Wrong With This Car? (6 replies)
  119. Speedometer Doesn't Work Error 64 (18 replies)
  120. Gearbox Oil (22 replies)
  121. Car Won't Start (5 replies)
  122. Trying To Remove The Sump Plug (3 replies)
  123. Twinspark Ticking Noise (could Be Oil Related) (5 replies)
  124. Throttle Valve - Does This Need Cleaning? (12 replies)
  125. Water Temp Sensor? (8 replies)
  126. Alfa 145 1.4? (15 replies)
  127. Loctite Oil Cooler Fitting? (3 replies)
  128. Front Brake Pipe Replacement (3 replies)
  129. Luckily I Work For... (8 replies)
  130. Oil Pressure Problem (19 replies)
  131. Bbob Traumas (9 replies)
  132. Keeps Cutting Out (10 replies)
  133. Molyslip In Engine Oil? (8 replies)
  134. My Maf Has Failed ! (5 replies)
  135. 145 Qv Not Running Right (35 replies)
  136. Twinspark Engine Removal Through The Top (8 replies)
  137. Spark Plugs For Ar145 Ts Cloverleaf (9 replies)
  138. Exhaust... (5 replies)
  139. New Engine (21 replies)
  140. Tapping Noise From Head (3 replies)
  141. Twinny Reduction 74db (9 replies)
  142. Mot Fail. Emissions (13 replies)
  143. Performance Chip From Performancechiptuning.com (3 replies)
  144. P1653 Variable Camshaft Timing Control Error (7 replies)
  145. How I Changed My Coolant The Other Sunday (0 replies)
  146. Four Pin Maf (4 replies)
  147. Car Just Cut Out...... (15 replies)
  148. Down On Power - Coil Packs? (2 replies)
  149. Ph2 Qv Ecu Question (5 replies)
  150. Starting Randomly (32 replies)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.