IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Windscreen washer Pump
duemila
post 29th April 2019 16:56
Post #1 | Print


1.3 8v
*

Group: Member
Posts: 26
Joined: 2nd November 2012
Local Time: 19th August 2019 17:31
Member No.: 10,639
Driving: alfa 145 qv
From: bedford



I'm not getting any water anymore out of the washer jets or headlight jets, I've turned the lights on also, I've checked the fuses, and I've swapped the connections round on both pumps, still nothing, I've sourced the windscreen dual pump, but does anyone know where you can get the headlight pump, Thanks
Go to the top of the page
View Vehicles
+Quote Post
dante giacosa
post 30th April 2019 08:05
Post #2 | Print


1.6 16v
****

Group: Veteran
Posts: 1,065
Joined: 28th March 2017
Local Time: 19th August 2019 17:31
Member No.: 13,068
Driving: 146 CF2 1.8 T-spark
From: Edinburgh



hey Duemila-

can you hear the motor 'trying' to work..? have you established voltage..?

The world is filled with rubbish Alfa washer-pumps- the best thing you can do is try for a new one, or at least a 2nd hand genuine one

otherwise you'll be disappointed.

I've always sourced mine from eBay; however; I don't see one at the moment

might be worth trying Neil @

http://italiaautoparts.co.uk
Go to the top of the page
View Vehicles
+Quote Post
donutty
post 30th April 2019 08:32
Post #3 | Print


1.4 16v
**

Group: Regular
Posts: 107
Joined: 27th November 2018
Local Time: 19th August 2019 17:31
Member No.: 13,545
Driving: 145 2.0 '96 Cloverleaf
From: Sheffield, UK



Having just changed the front and rear (same pump) washer pump, it's quite an easy job as they just push-fit in. All you need to do is move the engine cooling header tank to the side and lever it out.

A lot of online ePER is broken, but here I found out the p/n for the headlight washer pump: http://auto-kat.com/index.php?route=saleep...bgroup=55514_00

This shows as being compatible:

https://www.autodoc.co.uk/car-parts/oem/82439887

This post has been edited by donutty: 30th April 2019 08:33
Go to the top of the page
View Vehicles
+Quote Post
JeremyG
post 30th April 2019 08:37
Post #4 | Print


1.6 8v
***

Group: Regular
Posts: 514
Joined: 19th August 2016
Local Time: 19th August 2019 17:31
Member No.: 12,797
Driving: 166 3.0 Sportronic, GT 2.0 JTS
From: Oxford



Definitely agree that you should use genuine pumps for the screen washer - twice I've bought pattern parts and twice they've been useless.

Genuine pumps are available for £25 from www.shop4parts.co.uk here:

https://www.shop4parts.co.uk/?name=store&am...6v_Washer_Parts

As to the headlamp washer pump - I'm not sure I'd bother fixing this, unless you drive on very muddy roads at night often...
Go to the top of the page
View Vehicles
+Quote Post
dante giacosa
post 30th April 2019 11:50
Post #5 | Print


1.6 16v
****

Group: Veteran
Posts: 1,065
Joined: 28th March 2017
Local Time: 19th August 2019 17:31
Member No.: 13,068
Driving: 146 CF2 1.8 T-spark
From: Edinburgh



shop-4-parts!

of course doh.gif
Go to the top of the page
View Vehicles
+Quote Post
duemila
post 30th April 2019 11:53
Post #6 | Print


1.3 8v
*

Group: Member
Posts: 26
Joined: 2nd November 2012
Local Time: 19th August 2019 17:31
Member No.: 10,639
Driving: alfa 145 qv
From: bedford



Thanks for the advice, I've tested for voltage all good, I don't hear the pump, I did try it a couple of times when it was out of water last week, not sure if that killed it off, I will try the link thanks
Go to the top of the page
View Vehicles
+Quote Post
JeremyG
post 30th April 2019 14:50
Post #7 | Print


1.6 8v
***

Group: Regular
Posts: 514
Joined: 19th August 2016
Local Time: 19th August 2019 17:31
Member No.: 12,797
Driving: 166 3.0 Sportronic, GT 2.0 JTS
From: Oxford



QUOTE(dante giacosa @ 30th April 2019 12:50) *
shop-4-parts!

of course doh.gif


shop4parts are awesome - great service and super-efficient. And reasonable, too...

Which reminds me, I'd volunteered myself to put together an Alfa suppliers list... will get to that later.

This post has been edited by JeremyG: 30th April 2019 14:51
Go to the top of the page
View Vehicles
+Quote Post
duemila
post 2nd May 2019 12:53
Post #8 | Print


1.3 8v
*

Group: Member
Posts: 26
Joined: 2nd November 2012
Local Time: 19th August 2019 17:31
Member No.: 10,639
Driving: alfa 145 qv
From: bedford



I got the new pump from the link Thanks Jeremy, quick question is the blue additional bit on the front of my existing one the filter, do I swop that on to the new part,
Go to the top of the page
View Vehicles
+Quote Post
donutty
post 2nd May 2019 15:28
Post #9 | Print


1.4 16v
**

Group: Regular
Posts: 107
Joined: 27th November 2018
Local Time: 19th August 2019 17:31
Member No.: 13,545
Driving: 145 2.0 '96 Cloverleaf
From: Sheffield, UK



QUOTE(duemila @ 2nd May 2019 13:53) *
I got the new pump from the link Thanks Jeremy, quick question is the blue additional bit on the front of my existing one the filter, do I swop that on to the new part,


I think this is the 2 way valve thing that switches between the front and rear window - reversing the polarity of the supply makes the pump go the other way around and that blue thing uses this to divert the water one of two ways ?? Or at least that's what I thought it was for...
Go to the top of the page
View Vehicles
+Quote Post
JeremyG
post 3rd May 2019 07:08
Post #10 | Print


1.6 8v
***

Group: Regular
Posts: 514
Joined: 19th August 2016
Local Time: 19th August 2019 17:31
Member No.: 12,797
Driving: 166 3.0 Sportronic, GT 2.0 JTS
From: Oxford



QUOTE(donutty @ 2nd May 2019 16:28) *
I think this is the 2 way valve thing that switches between the front and rear window - reversing the polarity of the supply makes the pump go the other way around and that blue thing uses this to divert the water one of two ways ?? Or at least that's what I thought it was for...


Yes, thatís tight - on the genuine (black) pumps there is no blue blob on the front so no need to transfer that part from the old pump.

The filter is a push fit onto the pump inlet that sticks into the tank and it was completely clogged on my car. Unfortunately, it dropped into the tank as I was removing the pump. I removed the tank to recover the filter (although I guess you could fish it out without doing so).

HTH!

This post has been edited by JeremyG: 3rd May 2019 07:09
Go to the top of the page
View Vehicles
+Quote Post
duemila
post 6th May 2019 12:12
Post #11 | Print


1.3 8v
*

Group: Member
Posts: 26
Joined: 2nd November 2012
Local Time: 19th August 2019 17:31
Member No.: 10,639
Driving: alfa 145 qv
From: bedford



So I managed to fit the new pump, after I reminded myself why I work in an office and generally shouldn't touch my cars other than to put fuel and check the oil, first I attempted removing the pump by squeezing my hand in the gap, my hands now look like I'm a bare knuckle fighter, then after cursing at the design which requires one of the tubes to feed under the pump next to it, I undid the header tank and moved it out the way, I could only get the left side tube off by pulling and removing the headlight pump, somehow when refitting the headlamp pump I pushed in the rubber on the end into the bottle, luckily I have a mechanic across the road and he fished it out with a long grabber type thing, anyway I now have windscreen jets working, nothing out the rear but that's a job for another day.
Go to the top of the page
View Vehicles
+Quote Post
dante giacosa
post 7th May 2019 07:36
Post #12 | Print


1.6 16v
****

Group: Veteran
Posts: 1,065
Joined: 28th March 2017
Local Time: 19th August 2019 17:31
Member No.: 13,068
Driving: 146 CF2 1.8 T-spark
From: Edinburgh



well, it's a shame to hear that-

yes; a pair of long-nosed pliers or tools of any kind can be invaluable for such a task.

Despite being 'relatively' accessible, and not requiring anything to be undone; it can be immensely physical in directions that humans can't manage...
Go to the top of the page
View Vehicles
+Quote Post

Reply to this topicStart new topic

 



- Lo-Fi Version Time is now: 19 Aug 2019 16:31