Printable Version of Topic

Click here to view this topic in its original format

Alfa Romeo 145 - 146 Forum _ ECU Diagnostics _ Can't connect to engine ECU anymore.

Posted by: benedusi 6th March 2017 13:10

Last week, for no reason, the car didn't start, I tried to scan for errors using the VAG-COM and multiecuscan but it won't connect to the engine ECU as it used to, I tried with the ABS ECU and it connects right away.
Couple of hours after I gave up, the car just starts fine with no warning lights, but still no connection with the ECU. So I took the car to the mechanic to see if we could connect with the "real deal" scanner, and nothing.
Any ideas what could be wrong?

Posted by: benedusi 20th March 2017 20:06

Fixed, the floor on the passenger side was wet, probably the humidity had affected the ECU, so, I took it out, cleaned the connector, plug it in again and done.
Also I discovered that the drain holes were filled with dirt, and that caused the water to enter the cabin.

Powered by Invision Power Board (
© Invision Power Services (