Printable Version of Topic

Click here to view this topic in its original format

Alfa Romeo 145 - 146 Forum _ You & Your Car _ Passed MOT!

Posted by: Ganz 28th October 2019 23:47

The Bella passed her MOT today. Another year on the road smile.gif

The 147 Selespeed not so good. I got the old Selespeed system failure which resulted in the gearbox being stuck in first gear. No neutral means you cannot even push it. Had to get 4x4 to drag it out the way as it was blocking the entrance to the lockup compound. Its too good to scrap and if you own an Alfa you'll know you gotta be up for a challenge. Still, I must be mad laugh.gif

Posted by: dante giacosa 29th October 2019 13:46

ah...

I've just asked you about the 147 on another thread- I feared it might be the case

great news about the '45 though, got my own test on the '46 tomorrow...


Posted by: Ganz 2nd November 2019 22:06

QUOTE(dante giacosa @ 29th October 2019 13:46) *
ah...

I've just asked you about the 147 on another thread- I feared it might be the case

great news about the '45 though, got my own test on the '46 tomorrow...


All the best with yours man. Mine originally failed on the following, split inner CV boots. This is what happens when you lower a cars suspension. It changes the drive shaft angle and trashes the boots. Recommended the soft Flexi boots as they seem to provide the plianancy and are not the brittle type of GKN rubber that isn't up to the job. Tiny hole that turned into a bigger one on the bottom end of the offside sill that needed welding up. Make sure you leave the side skirt holes unless they are rotted too. Lack of horn on steering wheel as I have a momo steering wheel (found a Ripspeed one lol at Newark autojumble for 2), Driver's seat twisted on left side, blown nearside high beam. Advisories are nearly worn insides of my year old laser tracked Nagkangs!! Me and my mate mechanic fixed those and it passed.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)