IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Passenger Powered Window Problems, My powered passanger window does not open at all. what could be the pr
molekeng
post 20th May 2007 20:50
Post #1 | Print


1.3 8v
*

Group: New Member
Posts: 1
Joined: 20th May 2007
Local Time: 18th October 2018 13:09
Member No.: 2,451
Driving: alfa 145 quadrifoglio
From: Pretoria,South Africa



I have an Alfa 145 Quadrifoglio (98 model), the powered passanger window does not open nor close at all except the drivers side.What could be the problem?
Go to the top of the page
View Vehicles
+Quote Post
adey
post 21st May 2007 16:36
Post #2 | Print


1.4 16v
**

Group: Regular
Posts: 112
Joined: 9th January 2007
Local Time: 18th October 2018 12:09
From: North Shields
Member No.: 2,160
Driving: 156 JTDm, Fiat Multipla (yes-Italian beauty and ugliness!), Subaru Impreza plus Lotus 7
From: North Shields



QUOTE(molekeng @ 20th May 2007 21:50) *
I have an Alfa 145 Quadrifoglio (98 model), the powered passanger window does not open nor close at all except the drivers side.What could be the problem?


The rocker switch?
Perhaps a fuse if it's separate from the drivers side (which I think is the case)
Then starting to get more tricky - motor burnout as possibility
Go to the top of the page
View Vehicles
+Quote Post
MyFirstAlfa
post 26th May 2007 09:52
Post #3 | Print


1.4 16v
**

Group: Regular
Posts: 143
Joined: 5th May 2006
Local Time: 18th October 2018 12:09
From: Bristol
Member No.: 1,482
Driving: Alfa 145 Cloverleaf '96 & Renault Clio 182
From: Portishead, UK



QUOTE(molekeng @ 20th May 2007 21:50) *
I have an Alfa 145 Quadrifoglio (98 model), the powered passanger window does not open nor close at all except the drivers side.What could be the problem?


So you're saying the passenger window doesn't work from either switch, but the driver's window does work. Correct?

Is the fuse OK? On the phase 1 model the passenger window is on the same fuse as the boot release. Does your boot release work?
Go to the top of the page
View Vehicles
+Quote Post
Greigjolly
post 29th May 2007 09:54
Post #4 | Print


1.3 8v
*

Group: Member
Posts: 43
Joined: 19th April 2007
Local Time: 18th October 2018 11:09
Member No.: 2,395
Driving: 145QV
From: Leamington Spa



QUOTE(MyFirstAlfa @ 26th May 2007 10:52) *
So you're saying the passenger window doesn't work from either switch, but the driver's window does work. Correct?

Is the fuse OK? On the phase 1 model the passenger window is on the same fuse as the boot release. Does your boot release work?



i have exactly the same issue - passenger side leccy window wont work but drivers one does - just checked and my boot release doesnt work so im guessing this is the problem - also notable is that the little light behind the button for the windows doesnt come on with the headlights on the passenger side bit does on the drivers.

where is the fuse located/what sort?

cheers,

Greig
Go to the top of the page
View Vehicles
+Quote Post
MyFirstAlfa
post 2nd June 2007 13:11
Post #5 | Print


1.4 16v
**

Group: Regular
Posts: 143
Joined: 5th May 2006
Local Time: 18th October 2018 12:09
From: Bristol
Member No.: 1,482
Driving: Alfa 145 Cloverleaf '96 & Renault Clio 182
From: Portishead, UK



QUOTE(Greigjolly @ 29th May 2007 10:54) *
i have exactly the same issue - passenger side leccy window wont work but drivers one does - just checked and my boot release doesnt work so im guessing this is the problem - also notable is that the little light behind the button for the windows doesnt come on with the headlights on the passenger side bit does on the drivers.

where is the fuse located/what sort?


Just wrote a lengthy reply only for the webpage to "expire". Well here goes again...

Fuse is below (behind) and to the right of the main fuse array under the steering wheel. Green 30 A in a green fuse holder.

Power flows from ignition switch through a relay which switches power between boot release and passenger window circuit: ignition off - boot release on, window power off; ignition on - boot release off, window power on.

Relay sends power to passenger window switch in driver's door then across the dash to the passenger door switch.

You can diagnose as follows:

1) Replace fuse
2) If fuse blows with ignition off then problem with boot release circuit - if OK operate boot release a few times to confirm
3) Confirm fuse still OK and turn ignition on
4) If fuse blows instantly then you have a short somewhere
5) Ignition off, unplug passenger door switch and turn ignition on again
6) If fuse blows then short is upstream of passenger door switch - go to 8)
7) If fuse OK then short is between switch and motor - jiggle wires going into door to confirm. Investigage further door components of window system
8) Ignition off, unplug passenger window switch in driver's door and turn ignition on again
9) If fuse blows then short is upstream of switch in driver's door
10) If fuse OK, then short is between the two switches - jiggle wires doing into driver's door to confirm
11) You can then investigate the relay & wiring to the right of the steering wheel behind the fascia (click).

Good luck.
Go to the top of the page
View Vehicles
+Quote Post
Greigjolly
post 5th June 2007 09:13
Post #6 | Print


1.3 8v
*

Group: Member
Posts: 43
Joined: 19th April 2007
Local Time: 18th October 2018 11:09
Member No.: 2,395
Driving: 145QV
From: Leamington Spa



thankyou very much for this, much appreciated - will have a look as soon as i get some free time this week!

cheers,

Greig
Go to the top of the page
View Vehicles
+Quote Post
Malcolm
post 20th April 2018 19:55
Post #7 | Print


1.3 8v
*

Group: New Member
Posts: 1
Joined: 10th November 2013
Local Time: 18th October 2018 12:09
Member No.: 11,329
Driving: Alfa 145 1.8TS
From: London



QUOTE(Greigjolly @ 5th June 2007 10:13) *
thankyou very much for this, much appreciated - will have a look as soon as i get some free time this week!

cheers,

Greig



My 1998 Alfa 145 1.8TS passenger window stopped working from both LH and RH door switches. The driver side works fine. Unlike the driver side switch, the switch lights do not power and when pressed, there is no click heard from the relay. The suspect RH door switch works when you swap it over to the driver side connector so there is nothing wrong with the switch itself. All 3 fuses are fine and the boot opener works. I was wondering if it's a problem with the relay, a wiring fault, the window control unit or the window motor. It happened sometime during this cold winter weather. Any thoughts welcome, including where to find the I12 relay and whether that can fail for the window but still work for the boot opener. If the motor is faulty, presumably you should still hear the relay click if everything else is sound?

Cheers
Malcolm

This post has been edited by Malcolm: 20th April 2018 20:40
Go to the top of the page
View Vehicles
+Quote Post

Reply to this topicStart new topic

 



- Lo-Fi Version Time is now: 18 Oct 2018 11:09