IPB

Welcome Guest ( Log In | Register )

119 Pages V   1 2 3 > »  Start new topic
> Twin Spark Engine Only Oily Stuff
    Topic Title Replies Topic Starter Views Last Action
No New Posts  
My Alfa 145 QV Died
A lot of errors, cant figure whats wrong.
5 samsagaz 305 13 Nov 2017 16:44
Last post by: dellsbells
No New Posts  
6 zanetti 161 6 Nov 2017 00:42
Last post by: Ganz
No New Posts  
Pistons
Which pistons could be used?
2 zanetti 113 26 Oct 2017 04:51
Last post by: zanetti
No New Posts  
Pistons
Which pistons could be used?
0 zanetti 61 25 Oct 2017 12:44
Last post by: zanetti
No new  
Topic has attachmentsDiy Cambelt Change  * 123
Help & Advice
57 buellboy 29,422 11 Jun 2017 00:55
Last post by: Ganz
No new  
Topic has attachmentsQV won't start  * 123
no fuel, no spark
42 zanetti 4,238 11 Apr 2017 10:06
Last post by: GialloEvo94
No New Posts  
Accelerate issue
Alfa 145 1.4 TS accelerate issue, hiccups, irregular idle speedů
0 Alfi 212 21 Mar 2017 19:56
Last post by: Alfi
No New Posts  
2 TheOneAnt 499 21 Feb 2017 15:20
Last post by: TheOneAnt
Moved  
-- Edgar -- 2 Feb 2017 05:28
Last post by: Edgar
No New Posts  
2.0 TS alloy cover VS plastic cover
engine swap possible?
11 billyleung_146 1,936 27 Jan 2017 18:39
Last post by: black 146
No New Posts  
6 eskafiador 2,783 7 Jan 2017 22:03
Last post by: Ganz
No New Posts  
Topic has attachmentsSerpentine power steering hose
Serpentine power steering hose CF1
8 Ganz 1,547 7 Jan 2017 21:44
Last post by: Ganz
No New Posts  
6 samsagaz 2,105 27 Dec 2016 13:45
Last post by: purple
No New Posts  
3 peter79 2,100 14 Dec 2016 19:46
Last post by: peter79
No new  
Cloverleaf hesitation when cold
2001 cloverleaf juddering
16 Dmoore30 2,498 11 Nov 2016 17:22
Last post by: pyle
No New Posts  
9 JeremyG 1,688 2 Nov 2016 22:17
Last post by: JeremyG
No New Posts  
5 pyle 1,634 31 Oct 2016 20:13
Last post by: pyle
No New Posts  
3 mrmarkyt 1,059 25 Oct 2016 20:06
Last post by: mrmarkyt
No New Posts  
7 JeremyG 1,207 23 Oct 2016 10:44
Last post by: JeremyG
No New Posts  
Alfa Romeo 146 no power
Sensor failure or ?
12 Yoshevski 1,616 2 Oct 2016 20:44
Last post by: GialloEvo94
119 Pages V   1 2 3 > »  Start new topic
New Posts  New Replies
No New Posts  No New Replies
Hot topic  Hot Topic (New)
No new  Hot Topic (No New) 
Poll  Poll (New)
No new votes  Poll (No New)
Closed  Locked Topic
Moved  Moved Topic
 



Remember these options

- Lo-Fi Version Time is now: 19 Nov 2017 10:37